Welcome, Guest
Username: Password: Secret Key Remember me
  • Page:
  • 1

TOPIC:

Battery isolator clicking, sometimes? 8 years 11 months ago #10111

  • monkey44
  • monkey44's Avatar Topic Author
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 1258
  • Thank you received: 106
I shorted out my bed-plug a week ago on the road. Not a fuse, couldn't figure it out. Carry a pig-tail with me 7-pin, So, plugged it in to trailer plug near my hitch ... all lights work fine, battery charges SLOW, but charges (My in-bed plug has higher gauge wire, so charges faster).

Some of the time, when I stopped at a rest stop, the isolator was making a clicking sound. Not always, just sometimes, lasted for ten-fifteen minutes, then stopped. When it clicks, the lights dim, then clicks again, and the lights brighten. SO, it must be cycling?

At those times, the battery was not charged all the way full when we stopped - I think not charged full anyway. We drove for six hours with battery charging, but still not full - left in AM with 50%.

And can't actually get the battery full-charge now (shore power does full charge but truck does not), but just most of a charge - charge gauge reads bottom green light, but not full green light. Any thoughts on this clicking isolator?

When truck is running, top full charge light is lit, but when I shut off the truck, it drops to the middle green light - (from the top = four lights, green, green, yellow, red)

Just got home and will fix in--bed plug, but wonder what's going on with the isolator and why it clicks with the 7-pin and not the in-bed plug (or if that's even relevant).

And, this isolator was replaced during a recall a couple months ago, so should be good.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.381 seconds